Technical Requirements

Last updated: 05-22-2017

To provide you the most effective and secure online access to Highland Bank accounts and services, we strongly recommend that you use or upgrade to the latest version of software supported by Highland Bank.

If you have any questions, please contact us.

Browser Requirements

In compliance with industry standard best practices Highland Bank will be discontinuing support for TLS versions 1.0 and 1.1. In order to ensure that your service is not interrupted please confirm that your web browser supports TLS 1.2.



Browser TLS 1.2 Compatibility Notes
Microsoft Edge Compatible by default
Desktop and mobile versions Compatible by default
Microsoft Internet Explorer (IE)
Desktop and mobile IE version 11 Compatible by default
Desktop IE versions 9 and 10 Capable when run in Windows 7 or newer, but not by default.
Desktop IE versions 8 and below Not compatible or stable with TLS 1.2 encryption.
Mozilla Firefox Compatible with the most recent, stable version, regardless of operating system
Firefox 27 and higher Compatible by default
Firefox 23 to 26 Capable, but not by default.
Firefox 22 and below Not compatible with TLS 1.2 or higher encryption.
Google Chrome Compatible with the most recent, stable version, regardless of operating system
Google Chrome 38 and higher Compatible by default
Google Chrome 22 to 37 Capable when run in Windows XP SP3, Vista, or newer (desktop), OS X 10.6 (Snow Leopard) or newer (desktop), or Android 2.3 (Gingerbread) or newer (mobile)
Google Chrome 21 and below Not compatible with TLS 1.2 encryption.
Google Android OS Browser
Android 6.0 (Marshmellow) and higher Compatible by default
Android 5.0 (Lollipop) and higher Compatible by default
Android 4.4 (KitKat) to 4.4.4 Capable, but not by default.
Android 4.3 (Jelly Bean) and below Not compatible with TLS 1.2 encryption.
Apple Safari
Desktop Safari versions 7 and higher for OS X 10.9 (Mavericks) and higher Compatible by default
Desktop Safari versions 6 and below for OS X 10.8 (Mountain Lion) and below Not compatible with TLS 1.2 encryption.
Mobile Safari versions 5 and higher for iOS 5 and higher Compatible by default
Mobile Safari for iOS 4 and below Not compatible with TLS 1.2 encryption.